Symptom
When candidates tries to fill up and submit again the Data Capture form which they have already submitted in the past, they are getting the message "There's already a profile associated with the email address you provided, so we can't create a new profile."
Environment
SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- Fill up and submit the data capture form that does not came from an Email Campaign.
- Using the same email address try and update the other fields with a different value.
- Error appears "There's already a profile associated with the email address you provided, so we can't create a new profile".
Cause
When candidate submits data in DCF, RMK is calling an RCM API to create candidate (as there is no oauth token) and when RCM throws error that user is existing message. UI code gets the error code but tries to use the same success message to user leading to confusion.
Resolution
This is an expected behavior now. Previously, candidates are getting a message that their profile is being updated when they submit the data capture form again but it isn't. In general, Data Capture form is not designed to be used for candidates to update their candidate profile publicly. As when they have submitted the form and created their candidate profile, they should be able to update their information on their candidate profile. Candidates will be able to update their candidate profile once they have received an email campaign. Additional information regarding New and Existing Candidates is available on the implementation guide.
See Also
2659615 - CRM - Data Capture Forms and Landing Pages - Recruiting
Keywords
Update profile, Data Capture Form, Existing candidates, RMK-27546 , KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , Problem