SAP Knowledge Base Article - Public

3124541 - Updating candidate profile information via Data Capture Form - Recruiting Marketing

Symptom

  • When candidates tries to fill up and submit again the Data Capture form which they have already submitted in the past, they are getting the message "There's already a profile associated with the email address you provided, so we can't create a new profile."
  • Candidate only sees a few fields on the landing page compared to the ones configured on the data capture form. 

Environment

SAP SuccessFactors Recruiting Marketing

Reproducing the Issue

  1.  Fill up and submit the data capture form that does not came from an Email Campaign.
  2.  Using the same email address try and update the other fields with a different value. 
  3.  Error appears "There's already a profile associated with the email address you provided, so we can't create a new profile". 
  4.  Access the Email Campaign shared by Recruiter 
  5.  Only few fields are showing. 

Cause

  • Candidate profile has already created for email address being used. 
  • Candidate has already filled out the other fields previously. 

Resolution

  • Candidate can only be authenticated if the Landing Page with Data Capture form is added on the email campaign. 
  • It is expected that candidates will only see the fields that they haven't field up yet once the same landing page with DCF is shared to the candidate via email campaign. 

See Also

Keywords

Update profile, Data Capture Form, Existing candidates, dcf, update, change, missing , KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , Problem

Product

SAP SuccessFactors Recruiting all versions