SAP Knowledge Base Article - Public

3125872 - Migration of Service Contract - SAP S/4HANA Cloud

Symptom

Post migration of Service Contracts, the field 'External Reference' appears blank in the "Manage Service Contract" app.

Environment

SAP S/4HANA Cloud.

Reproducing the Issue

  1. Open 'Migrate your data' App.
  2. Access the relevant Migration Project.
  3. Select the Migration Object 'Service Contract'.
  4. Migrate.

Cause

Field "Purchase Order by Customer" (PURCHASEORDERBYCUSTOMER) is blank in the Migration template.

Resolution

In the migration template, the key identifies a service contract, and related item, text. This field does not pass as Service Contract ID in the Fiori App. The transactional id gets generated and saved in the system.

The field "External Reference" in the Fiori app is same as the field "Purchase Order by Customer" in the migration template. Hence if this field "Purchase Order by Customer" is filled in the migration template, the external reference field appears in the 'Manage Service Contract' App. 

See Also

Service contract

Keywords

Service, contract, ca-gtf-mig, external, reference, Purchase, Order, by, Customer, ID, manage, ca-lt-mc, S/4HANA Cloud, S4_PC. , KBA , CA-GTF-MIG , SAP S/4HANA Data Migration Cockpit Content , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions