Symptom
You are trying to edit the button "Use Existing Account" when creating a new Lead from a Ticket or from an Unassociated E-Mail, however the button is grayed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Service work center.
- Go to the Tickets View
- Open any Ticket.
- Click "+".
- Create a new Lead.
- See that the 'Use Existing Account' button is grayed out.
NOTE: the same behaviour is true for the scenario of creating a lead from an Unassociated E-Mail. The unassociated e-mail does not yet have an account maintained. When creating a lead from that object, however, the system expects a reference account and the 'Use Existing Account' is set to 'yes' and grayed out.
Cause
The creation of Lead via any reference object (such as Ticket or Unassociated E-Mail in this example) is not supported without an existing account.
The button can only be used during stand-alone Lead creation where there is no account involved yet.
The Account data gets copied from the obect the lead is being created out of, into the Lead (here, Ticket/ Unassociated E-Mail, however, the same is true for any other object). Only if no reference object (predecessor lead/ unassociated e-mail, etc.) is involved is it allowed to use the "Use Existing Account" = No button in a lead.
Resolution
This is the expected system behavior.
Keywords
Lead ; Creation ; Account ; Ticket ; Edit , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-SRP , Service Request Processing , How To