SAP Knowledge Base Article - Public

3126089 - Unsubscribe Recipient - Onboarding

Symptom

  • Notification are triggered but not getting received
  • Recipient is showing in the Unsubscribed Recipient
  • Why recipients are not getting the notification?

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Admin Center > Email Services > Email Status
  2. Check affected notification
  3. Notification status is SENT, but you are seeing recipients under Unsubscribed Recipient.

Cause

  • As an email recipient, if user clicked the unsubscribe here link in the notification email this will redirect the user to the account settings page of the SAP SuccessFactors HCM Suite and turned off notification by selecting the option Read messages in the system.
  • An inactive user uses the same email with the impacted user.

Resolution

Troubleshooting/Resolution:

  1. Check if this option is disabled.
    • Admin Center > Company System and Logo Settings > there is a setting called "Restrict email notification preference settings to administrators only." which allows company admins to control the permission whether to allow users to set their notification preferences.
      (Previously this setting was called "This option allows a company-wide setting on whether users will receive Email notifications. If 'checked', all users will receive Email on all workflow related process. If not checked, each user has an option to turn notification on/off.") Check if user switched off notification.
    1. In the user's home page, click profile (upper right hand corner)
    2. Next, click Settings/Options
    3. Then, click Notifications
    4. If option selected is "Read messages in the system", it means that the user will not receive the notification. 
      • Note2: If user wish to subscribe to email notifications again, go to Options/Settings > Notifications from your user profile menu on the Home page. Select Send emails to me and click Save Notification. 
  2. Export employee data through Employee Export and check if any other user share the same email of the impacted user. 
    • Purge the inactive user or update the email of the inactive user to a dummy one. 

See Also

Keywords

unable to receive notification, recipient not getting notification, email sent but not received, unsubscribed recipient, recipient not getting notifications, disable notification, enable notification, turn off notifications, turn on notifications, unsubscribe, unsubscribe notification, EML, Email services, OBX, ONB, ONB2, Onboarding , KBA , LOD-SF-OBX , Onboarding 2.0 , LOD-SF-OBX-ADM , Admin UI , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions