Symptom
- Error: 'Failed to initialize MAPI. Please make sure MS Exchange Client/MS Outlook is installed properly.'
- When refreshing a report based on Outlook/Exchange in Crystal Reports, it fails.
- When attempting to connect to Outlook/Exchange from Crystal Reports, it fails with the error:
"Database Connector Error: ‘Failed to initialize MAPI. Please make sure
MS Exchange Client/MS Outlook is installed properly.’"
Environment
- SAP Crystal Reports 2016
- SAP Crystal Reports 2020
- MS Outlook 2013
- MS Outlook 2016
Reproducing the Issue
- In Crystal Reports, create a new report.
- In Database Expert, under "New Connection", double click on "Outlook/Exchange"
- It then generate the error: "… Failed to initialize MAPI. Please make sure MS Exchange Client/MS Outlook is installed properly."
Cause
- MS Outlook, not installed; or
- Version of MS Outlook installed not supported.
Resolution
- Install a supported version of MS Outlook for the version of Crystal Reports used:
- Confirm the version of MS Outlook, Crystal Reports supports by looking at the Supported Platforms document:
- Install a 32bit, or 64bit version of MS Outlook, depending on the version of Crystal Reports used:
- For Crystal Reports 2016:
- Install the 32bit version of MS Outlook.
- For Crystal Reports 2020:
- Install the 64bit version of MS Outlook.
Keywords
CR, MAPI , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2016 ; SAP Crystal Reports 2020