SAP Knowledge Base Article - Public

3126413 - Concurrent session license remain enforced after concurrent session license has been removed following contact change

Symptom

  • Upon logon to SAP Analytics Cloud, the error message 'No Sessions Available' is displayed and the user is thus unable the logon
  • Only the users that *used* to have a 'Business Intelligence Concurrent Session' license assigned to them are unable to login, other users do not have a problem with the logon

Environment

  • SAP Analytics Cloud Service (or tenant) without any Business Intelligence concurrent session licenses assigned to it. 
  • The SAP Analytics Cloud Service has recently had the Business Intelligence concurrent session licenses removed from it, following a change to the SAP contract.
  • SAP Analytics Cloud Service 2021.24 onwards

Reproducing the Issue

  1. With the SAP Analytics Cloud Service (or tenant) itself assigned at least one Business Intelligence concurrent session license:
    • Assign one or many users with the Business Intelligence concurrent session license
  2. The contract for SAP Analytics Cloud Service (or tenant) is changed or come to an end, resulting in the Business Intelligence concurrent session licenses being removed from the SAP Analytics Cloud Service (or tenant) itself.
  3. At the time of the contract change taking effect, the users remained with the Business Intelligence concurrent session license assigned to them
  4. After the contract change has taken effect, all users appear to have no Business Intelligence concurrent session license assigned to them as shown via the SCIM API (isConcurrent is false) and via the user interface
  5. Attempt to login with a user that used to have a Business Intelligence concurrent session license assigned to them (step 1 above) and remained assigned to them at the time the contract change took effect when the concurrent session license was removed from the SAP Analytics Cloud Service 

Cause

  • Under investigation by SAP development, however the concurrent session license remains enforced even though the SAP Analytics Cloud Service (or tenant) itself no longer has concurrent session licenses assigned to it.

Resolution

  • A full resolution is under investigation by SAP development.
  • Until a full resolution is in place please submit a Support Incident with SAP Product Support requesting Product Support to log an internal DevOps ticket requesting the development toggle INFRA_CONCURRENT_LICENSE_ENFORCEMENT to be turned off. This is a temporary workaround until the investigation by SAP development has completed.
  • Please note, this development toggle INFRA_CONCURRENT_LICENSE_ENFORCEMENT can only be turned off after any concurrent session licenses have already been removed and the toggle is applicable for a named SAP Analytics Cloud Service (or tenant). Please ensure you mention the URL of the SAP Analytics Cloud Service (or tenant) when you submit your SAP Product Support incident.
  • An alterative workaround is to change all the users Business Intelligence license type from 'concurrent session' to 'named' before the contact change is made. Please see the Blog & Article: SAP Analytics Cloud - Managing Licenses with Roles and Teams for more details on how to do this.

See Also

Keywords

SAC concurrent session license , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud all versions