SAP Knowledge Base Article - Public

3126507 - Scheduled and Current versions not matching for Integration Center job

Symptom

When running Integration Center Jobs you notice delta changes are not captured as expected. Upon further investigation you notice the current version of the job and the scheduled version of the job are not in sync.

Environment

  • SAP SuccessFactors HCM Suite
    • Integration Center

Cause

When you have a scheduled version of an Integration Center job, and you manually run the job, this will increase the current version of the job and the scheduled version will stay as is until next scheduled run.

Whenever the scheduled version and current version of the job are not aligned, the job will not pick Delta changes and will bring back all records from the scheduled version.

Resolution

Ensure the scheduled version and current version are in sync, i.e on the same version. This can be done by setting up a new schedule, so clear the schedule as it is and reset it, then both version should be matching.

See Also

  • 2573673 - How to stop a scheduled interface in Integration Center
  • 2567527 - Multiple versions still running after schedule is stopped - Integration Center
  • 2746667 - Integration Center: How to edit specific version of an Integration center job
  • Integration Center Guide Section 4.2.2.6 Scheduling

Keywords

Integration Center, Version, Scheduled Version, Current Version, Delta, Versions not in sync. , KBA , LOD-SF-INT-INC-JOB , Integration Center Job , LOD-SF-INT , Integrations , LOD-SF-INT-INC , Integration Center , How To

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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