Symptom
Some picklists display a "No Selection" value, even though such value is not configured in Picklist Center.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Platform
- SAP SuccessFactors Employee Central
- SAP SuccessFactors Employee Profile
Reproducing the Issue
- Go to an employee profile;
- Find a picklist field, such as Preferred Language;
- See the first value displayed is "No Selection";
- Now go to Manage Business Configuration;
- Find the picklist associated to the field;
- Go to Picklist Center;
- Open the concerning picklist;
- Search for "No Selection" and see there is no data found;
Cause
This happens when the field is not mandatory.
Even if you do not have a "No Selection" value configured in the picklist, system will automatically display such option, allowing employees to keep the field blank, given it is not mandatory and does not require being filled.
Resolution
Only mandatory fields will only display the values configured for the picklist in Picklist Center.
Once the field is set to "Mandatory = Yes" in Manage Business Configuration, the "No Selection" option will no longer be displayed.
Keywords
No Selection, Option, Value, Picklist, Field, Mandatory, Non Mandatory, BCUI, Manage Business Configuration , KBA , LOD-SF-PLT-PCK , Picklist Management Issue , LOD-SF-EC , Employee Central , LOD-SF-EP , People Profile , Problem