Symptom
There is a scenario where a profit center is created using the API API_PROFITCENTER_SRV, but the same is not found even after message 'Message processed successfully' is obtained.
Environment
SAP S/4 HANA Cloud Public Edition
Cause
In case of asynchronous SOAP API for profit centers, the API is always providing a successful message “message processed successfully”, when the passed message structure has a valid form. It doesn’t say that the data was already processed and a profit center was created.
Resolution
The meaning of the message is:
- The passed message was accepted by the API, and it is waiting in the queue on the processing.
- The outcome from the processing can be, that some invalid business data was passed, so the profit center will be not created in the system. This has to be checked in the message monitor.
- And suppose, a response is needed to get info about the processing from API, then the confirmation SOAP API has to be activated. More information on the same can be found in the Profit Center – Create, Delete .
Keywords
Manage Profit Centers, API, message processed successfully, API_PROFITCENTER_SRV, S4_PC, EC-PCA. , KBA , EC-PCA-MD-2CL , Master Data (Public Cloud) , Problem