SAP Knowledge Base Article - Public

3127427 - You are Updating a Sales Order or Contract via Web Service, but the System is not Passing the Items in the Expected Order

Symptom

You are updating a Sales Order or a Contract via the web service and want to add items in a sequential order. However, the system is not adding the items in the same order as you passed them via the web service.

Environment

SAP Business ByDesign

Reproducing the Issue

In this example we will use a sales order as an example. The sales order has already one item and you want to update the sales order with 3 additional items.
We will only use a a smal extract of the payload to represent the sequence you are uploading/updating to the Sales Order ABC (ABC represents the ID of the Sales Order).

<SalesOrder actionCode="04">
<ID>ABC</ID>
<Item actionCode="04">
<Description>1</Description>
</Item>
<Item actionCode="04">
<Description>2</Description>
</Item>
<Item actionCode="04">
<Description>3</Description>
</Item>

.

.

.
</SalesOrder>

Once the upload/update is concluded, you see the following inside the Items tab of the Sales Order document:

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. earch for ID ABC.
  4. Click Edit.
  5. Navigate to the Items tab.
    You can see that the items are added not in the same sequence and provided in the payload.
    Item 20 | Description: 2
    Item 30 | Description: 3
    Item 40 | Description: 1

Cause

This is a technical limitation. The system does not guarantee the item order.

Resolution

This is the current system behavior.

Please update the documents before the document is released, which will allow you the chance to pass the item ID.

See Also

2811862 - Error: Changing Line Not Possible; Field is Read-Only in Web Service

Keywords

Web Service, Sales Order, Contract, Update, Sequence, Order, Not Possible, Wrong; line items; item number , KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions