SAP Knowledge Base Article - Public

3128552 - "ADD-IN ERROR" Message In C4C Outlook Server Side Add-In

Symptom

You configured the Groupware Outlook server side integration and installed the add-in from Groupware Settings. However when in Outlook the add-in appears disabled (greyed out) and also the following error message appears:

"ADD-IN ERROR This Add-In could not be started. Close this dialog to ignore the problem or click "Restart" to try again."

addin_disabled.png

addin_error.png

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Access your Microsoft Outlook.
  2. Add-In will be disabled and error will show up on side pane.

Cause

The issue is caused by Microsoft Edge Webview runtime software and can affect any add-ins (also third parties).

Resolution

Engage your Microsoft Office support to follow the steps below:

1. Close Microsoft Outlook.
2. Close Microsoft Edge browser windows, if any are opened.
3. Download MS Edge Webview2 runtime from this location: https://go.microsoft.com/fwlink/p/?LinkId=2124703

If this package does not work in your configuration, install an alternative version.

Browse this Microsoft resource: https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section for versions compatible with different Microsoft Edge builds and x86, x64, or arm64 architecture.

4. Open your Downloads folder and install Webview2 on your Windows system. 
5. Launch Microsoft Outlook and check if Add-In can be opened and key sidebar controls are clickable.

See Also

The runtime’s security and stability are guaranteed by Microsoft, see this article for complete information on Webview2: https://devblogs.microsoft.com/microsoft365dev/understanding-office-add-ins-runtime/

Keywords

Groupware; Server side; Outlook; Integration; E-mail; Email; Add-in; Addin; Add-on; Addon; Side Pane; Side Panel; Error; Message; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions