SAP Knowledge Base Article - Preview

3128811 - PREP_INPUT_CHECK/TOOLVERSXML_EXTRACT error on RHEL 7, when upgrading to S/4HANA 2020 or 2021

Symptom

During upgrade to S/4HANA 2020 or 2021, the error is shown:

Severe error(s) occurred in phase PREP_INPUT_CHECK/TOOLVERSXML_EXTRACT!

...

./disp+work: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./disp+work)
./disp+work: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./disp+work)
./disp+work: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./disp+work)
./disp+work: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./disp+work)

The server is on Red Hat Enterprise Linux 7

The option "/S4H2020/allow/RHEL7SLES12 = ON" is used from note 3070403 to allow the upgrade on this OS version


Read more...

Environment

Red Hat Enterprise Linux 7

SUM 2.0

S/4HANA 2020 or 2021

Keywords

RHEL7, PREP_INPUT_CHECK/TOOLVERSXML_EXTRACT, compat-sap-c++, /usr/sap/lib, /S4H2020/allow/RHEL7SLES12, GLIBCXX_3.4.21 , KBA , BC-OP-LNX-RH , Red Hat Linux , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.