SAP Knowledge Base Article - Public

3129369 - Two Time Accounts are Created for Employee's for the Same Year

Symptom

  • Two time accounts have been created for the same dates
  • Manage Time Off Calendars shows two calendar runs for the same time
  • Duplicates the Time Accounts for employees

Environment

SAP Successfactors Employee Central Time Off

Reproducing the Issue

  1. In Manage Time Off Calendars, create a new Account Creation Calendar and Run.
  2. Once the calendar run is complete, see that there are two calendar runs that executed at the same time.
  3. Also, see two time accounts have been created in the users Time Account Workbench

Cause

This issue can occur if the Run button is double-clicked when submitting the Account Creation Calendar

Resolution

This is a known issue by the engineering team. They are currently working on a fix which is due to be implemented with the b2205 release (May 2022).

Workaround:

To correct the current accounts:

  1. Use the Check Tool > time off > time accounts > OverlappingTimeAccounts to identify the accounts
  2. Delete the redundant Time Accounts

See Also

2417228 - How to Delete a Time Account from Employee Central

Keywords

Duplicate, Time Account, Double, Calendar Runs Twice, TIM-29040, Manage Time Off Calendars, Account Creation Calendar , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-TIM-CAL , Calendar Jobs , Problem

Product

SAP SuccessFactors HXM Core 2111