Symptom
You have a report based on the Ticket data source (CRMSRQHB), and you notice that some service categories, cause categories, object categories etc have the wrong description.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Business Analytics and the view Design Reports.
- Open your report.
- Add the field Service Category, for example, and display the ID and description.
You will see that the description is wrong. It shows an older description from a previous catalog version.
Cause
You have various catalog versions, where category IDs were reused, only descriptions were changed. As a result, these IDs are not unique any more. In such cases, the display of category descriptions can be inconsistent and only the first category description is shown.
Resolution
This behavior cannot be avoided where category IDs were reused across catalog versions.
We would recommend to ensure that there are always unique category IDs in each version.
See Also
2718470 - Wrong Description of Service Categories in Report Charts
2693915 - Reporting on Ticket, Service Categories and Service Catalogues
3032022 - Catalog Category Descriptions are Missing in Ticket Reporting
2508155 - Multiple/Repeated Service Category Values Displayed in Report Filtering
Keywords
service category catalogue, wrong description, categories inconsistent, old text, catalog version, reporting, business analytics, analysis , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Product Enhancement