SAP Knowledge Base Article - Public

3129909 - Workflow Rule Type field is not visible while it has been set to "Visible" under adaptation mode

Symptom

Setting the "Rule Type" as visible in Adaptation Mode does not make the field visible in the UI

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to "Administrator" -> "Workflow Rules" WoC
  2. Create a new rule, and enter in Adaptation Mode
  3. Set the "Rule Type" object as "Personalize" and "Mandatory"
  4. Exit Adaptation Mode
  5. Check (no "Rule Type" has been added under the "Enter Basic Data" step)

Cause

Misunderstanding of the UI

Resolution

  • The system is working as designed
  • Workflow rules involve a five step process. See "Workflows" for more details 
  • The visibility of the "Rule Type" field is allocated to be under the "Define Actions" step, and not the "Enter Basic Data" step

Keywords

Workflow, adaptation, UI, C4C, Cloud for Customer, Visible, invisibility, Rule Type, , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer add-ins 1905 ; SAP Cloud for Customer add-ins 1908 ; SAP Cloud for Customer add-ins 1911 ; SAP Cloud for Customer core applications 2111