SAP Knowledge Base Article - Public

3129972 - Not Able to Sync Cloud for Customer App.

Symptom

You are using C4C App version older that the current tenant version and you are not able to sync the App and go to offline mode.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. On C4C App.
  2. Go to profile menu.
  3. Click on sync.
  4. Error message will be displayed.

Cause

With each new release, incompatible changes are being delivered for users working with offline functionality in Extended Apps. With each release update, users are recommended to use the latest version of the C4C App to connect to their system once updated.

Information on Incompatible Changes in Offline Functionality.

Resolution

In case you use the older version of the C4C App with the updated system, the data download will be blocked, but you can still work and upload offline changes based on the last version's code.

Keywords

C4C App, C4C App Version, Offline, Sync Offline. , KBA , AP-RC-MOB-OFL-RT , Offline Runtime , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions