Symptom
You have an issue where a KUT list field has the default value set to = "0", however, the system returns the following = "-" every time customer enters zero ("0").
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log into system.
- Go to products WC.
- Go to Products View.
- Search for any product.
- Open it.
- Start Adaptation Mode.
- Select the tile General Information.
- Go to your KUT field.
- Edit field.
- Click pencil and change the value of "Default value".
- If you change value of "Default value" to zero "0" it will become "-", if you change it to any other number it will stay that number.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
This happens because decimal numbers always have default value as "0", meaning even if you don't give any default value its treated as "0".
Also, data is stored as "0" but somehow in UI it is rendered as "-".
This is the system behavior and cannot be changed.
Resolution
This is the current system expected behavior.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
Default value; system behavior; , KBA , AP-RC-UIF , C4C UI Framework , How To