SAP Knowledge Base Article - Public

3132595 - Custom Field is not available for JobOffer entity - Recruiting Management

Symptom

A custom field from Job Requisition or Job Application was added into the Offer Approval template, but the field is not available in Integration Center or in the OData API Data Dictionary.

Environment

SAP SuccessFactors Recruiting Management

Cause

  1. The field is not editable (reportable) in Offer Details.
  2. The field is configured in 'Provisioning -> Configure Reportable Custom Fields' with a different field type (e.g. in Offer Approval Template the field is type="picklist" and in Provisioning is mapped to the Text type of reportable custom fields).
  3. The field is using a non-supported field type for the said referenced field (e.g. the field is type="textarea" and the template in use is Job Requisition)
  4. The field is configured in the Offer Approval Template with a different field type of the referenced template (e.g. in Offer Approval Template the field is type="picklist" and in the Job Application Template is type="text")

Resolution

To have available such field in the OData API Data Dictionary or Integration Center:

Cause 1 & 2:

  1. Go to Provisioning -> Configure Reportable Custom Fields.
  2. Select the source entity 'Job Req' or 'Application'.
  3. Add the Field ID to the correct field type and save.
  4. Execute 'Synchronize Existing Data' on the same page.
  5. Go to Admin Center -> OData API Metadata Refresh and Export.
  6. Execute a refresh.

Note: To complete tasks in Provisioning, please contact your Implementation Partner. If you are no longer working with an Implementation Partner, you can submit a change request to SAP Support using the approval document downloaded from the following KBA.

  • KBA 2258199 - SAP SuccessFactors Recruiting - Provisioning Configuration Changes
  • Request item: "Make a field reportable"

Cause 3:

It would be required to use the supported field type in the supported template, and adjust the Offer Details Template accordingly. As the example given in the cause, the type textarea is only supported if is coming from the Job Application, then this field in the Offer Approval Template must come from the Job Application to become available. Please also make sure that the field attributes are a match in both templates.

Cause 4:

When a field is used across templates with the same field ID, the information must be consist across templates and it must be intact. This means that when a field is used in more than one template, it must be an exact match of the field type. Otherwise, it can cause issues when reading the information from the database in Reporting or even in the UI.

NOTE: Do not modify the field type of an existing field, in special for fields that already had value in it. This causes corruption in the database, and can also cause issues and errors in the system. If the said field requires a different type, it is recommended to remove all of the permissions to write and read for the previous field type and create a new field with the required type instead. This way the historical data is also reportable.

Keywords

integration, center, job, offer, joboffer, entity, requisition, application, approval, letter, o, data, api, odata. , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , LOD-SF-RCM-API , Webservices & APIs , Problem

Product

SAP SuccessFactors Recruiting all versions