Symptom
Not able to find Agreement data in Segmentation .
Environment
- SAP Marketing Cloud Edition
- SAP Marketing OnPremise starting with release 1809
Reproducing the Issue
- Create a Contact in Marketing System
- Import Agreements for that Contact using API_MKT_AGREEMENT_SRV
- Import Monitor shows Import is successful
- Try to find the Agreement in the Segmentation / Operational Report Agreement
- Agreement is not shown in the UI
Cause
Agreement Terms not imported for Agreements.
Resolution
- To see the agreements in the segmentation not only the root but also the agreement terms (at least one) need to be imported.
- Although it is technically possible to create a root entry /Agreement without the corresponding entry for Agreement Terms, this would be semantically incorrect and these entries would not be usable in the segmentation and should therefore be avoided. A root entry without terms can only exist temporarily in the system due to a time lag between the creation of both entities.
See Also
Keywords
Agreements , Agreement Terms , Segmentation , KBA , CEC-MKT-SEG , Segmentation , CEC-MKT-DM-AGR , Agreement , CEC-MKT-DM-SEG , Segmentation Profiles for DM , Problem
Product
SAP S/4HANA Cloud 2111