SAP Knowledge Base Article - Public

3132730 - Time formatting does not change according to Profile Settings in SAP Analytics Cloud (SAC)

Symptom

Time formatting does not change according to Profile Settings in SAP Analytics Cloud (SAC).

Environment

SAP Analytics Cloud (Enterprise) 

Reproducing the Issue

  1. Login to SAC.
  2. Create an import/acquired model which contains 1 Dimension member, 1 Timestamp entry and 1 Measure value.
  3. Create a story based on the model.
  4. Insert a Text and add Dynamic Text, select Dimensions: [Timestamp]
  5. Check the added date and time => Time format: hh:mm:ss PM (which is 12 Hours format).
  6. Now check the user Profile Settings - Time Formatting => 24 Hour Format (hh:mm:ss) is set.
  7. If you change the Profile Settings - Data Access Language = Deutsch => time format will change to hh:mm:ss (24 Hour Format (hh:mm:ss))

Cause

The User Preference setting of Date Formatting & Time Formatting does not affect the dimension members formatting with Date or Time data type, but will impact date/time displayed for User’s information.

Resolution

Data formatting may be customized through the model definition and will be also impacted by the language selected via the Data Access Language setting.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-DES , Story Design & Visualizations , Problem

Product

SAP Analytics Cloud 1.0