SAP Knowledge Base Article - Public

3132838 - Goal Transfer Error in Business Process Tile - Onboarding

Symptom

  • Goals did not transfer from onboarding
  • Goal transfer error in business process tile
  • ONB2_GOAL_TRANSFER: ExecutionException while upserting goals for process with applicantId: 
    com.successfactors.coengine.error.detail.COGeneralBadRequestException: Error on field due & start Start Date has to be before 
    Due Date.

Environment

SAP SuccessFactors Onboarding

Cause

  • Due Date on goal task was the same date as the start date on onboarding process
  • Due date set for Set goals task in Manage Onboarding and Offboarding Tasks was -30 which is not valid

Resolution

  1. Navigate to Manage Onboarding and Offboarding Tasks
  2. Open Set goals task
  3. Change Due Date for each goal to number greater than 0
  4. Navigate to Manage data > goal task > search with process id > take action and change due date to date after start date
  5. Restart task from business process tile
  6. Error should be resolved and should not appear for future candidates as due date is updated in Manage Onboarding and Offboarding Tasks

Keywords

Transfer goals, goal error, ONB2_GOAL_TRANSFER, Exception while upserting goals for process with applicantId, Error on field due & start Start Date has to be before Due Date. , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem

Product

SAP SuccessFactors Onboarding 2111