SAP Knowledge Base Article - Public

3133896 - Filter in Drip Campaign Is Not Working

Symptom

You have created a drip campaign and added a filter to only send that particular email to a subset of the target group. You are expecting the filter to only be applied to the email where the filter is set, but instead, the filter is carried to all of the next emails sends.

Environment

SAP Marketing Cloud

 

Reproducing the Issue

  1.  Open the Campaigns app.
  2.  Create your drip campaign with for example 4 email node actions in sequence.
  3.  Set a filter based in a live target group in the first email action.
  4.  Execute the campaign.

You will note that even though the filter is maintained only in the first email note, the subsequent email actions will consider only the contacts which received the email in the first node, not the full target group.

Cause

The rebuild of the initial target group is only triggered during the first email execution, the next follow-up actions consider the member which received the previous Email_Outbound interaction.

 

This means that if you apply a filter in the second node of the emails of the drip campaign, the subsequent nodes will consider the member which received the email in the second node to build the execution.

Resolution

This is the expected system design when using filter to drip campaigns.

Keywords

Drip Campaign, Campaign Filter , KBA , CEC-MKT-CPG-EXE , Campaign execution , CEC-MKT-CPG , Campaign , How To

Product

SAP S/4HANA Cloud 2111