SAP Knowledge Base Article - Preview

3133984 - Error: 502 Proxy Timeout During ImpEx Execution in HAC or Storefront/Backoffice Access

Symptom

The following Proxy Error page appears when:

  • Running a large ImpEx script in HAC
  • Opening Backoffice with heavy data load
  • Accessing Storefront pages with high CORS load
Proxy Error
The proxy server received an invalid response from an upstream server
The proxy server could not handle the request
Reason: Error reading from remote server

In addition, during the error occurrence:

  • In Dynatrace, requests with response code 502 traces failing consistently after a fixed duration (e.g., 1 minute or 10 minutes), aligning with the configured proxy timeout value
  • In OpenSearch, the following logs can be found:
  • [proxy_http:error] [pid 14xxx7:tid 13xxxxxxxxxxx68] (70007)The timeout specified has expired: [client 4x.20x.21x.4x:5269x] AH01102: error reading status line from remote server xx.xx.xx.xx:8081
  • [proxy:error] [pid 14xxx7:tid 13xxxxxxxxxxx68] [client 4x.20x.21x.4x:5269x] AH00898: Error reading from remote server returned by /rest/v2/xxx/xxx

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.


Read more...

Environment

  • SAP Commerce
  • SAP Commerce Cloud

Product

SAP Commerce Cloud all versions ; SAP Commerce all versions

Keywords

Proxy Timeout, Error reading from remote server, proxy server, hybris, ccv2, response, request, 502, timing out, ImpEx, HAC, slow response, timeout , KBA , CEC-SCC-PLA-PL , Platform , CEC-SCC-CLA-ENV-EMG , Environment Management , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.