Symptom
When you try to create a Follow-Up Credit Memo from a Customer Invoice, you notice that the system takes a long time loading or generates an error after a few minutes.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Open the Invoice Documents view.
- Find Customer Invoice ABC (Where ABC represents the ID of the document you wish to create a Credit Memo from).
- Highlight the Line
- Click on the Follow-Up button and choose the Credit Memo option.
The next screen takes several minutes to load or fail to load after 10 minutes.
Cause
This behaviour is caused when the Account used in the Customer Invoice has many Relationships with the "Has Ship-To Party" attribute configured. When the system tries to create the Follow-Up Credit Memo, all those records need to be fetched and processed which can take a long time if the list is too long.
Resolution
You can check the Relationships by following these steps:
- Go to the Account Management work center.
- Open the Accounts view.
- Find Account ABC (Where ABC represents the ID of the Account used in the Customer Invoice).
- In the Account screen, click the View All button.
- Navigate to the Contacts tab.
- Open the Relationships and Responsibilities sub tab.
- Under the Relationships section you can see all the Relationships with "Has Ship-To Party" Maintained.
We recommend keeping less than 100 of such Relationships in the Account to ensure the performance of the Follow-Up operation.
Keywords
System, Long, Time, Processing, Slow, Follow-up, Performance, Relationship, Account , KBA , AP-CI-CI , Customer Invoice , How To