SAP Knowledge Base Article - Public

3136025 - Reference field in service order invoice doesn't store billing document ID

Symptom

When an invoice (F2) is created with reference to a service order, the invoice number is not stored in the reference field of the invoice. Instead, the service order number is stored in the reference field of the invoice.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open Manage service orders app.
  2. Click quick create and create service order screen pops up.
  3. Choose the customer, sales are and the products.
  4. Then cllick Save and Edit button. Note at the bottom of the page the Service Order number.
  5. In the next screen, go to the item and navigate to the price details (make sure the service order value is set right).
  6. Change Service Order status to COMPLETED.
  7. Then, click release for billing.
  8. Then, open 'Create Billing Documents' app and add filter 'BDR source document' field.
  9. Enter the Service Order number created in the previous app in the BDR source document field.
  10. Select the BDR from the resulting list and click create billing documents
  11. Temporary Invoice will be created on the next screen and then click on 'save' button.
  12. Check the reference field in the invoice screen, it will be populated with Service Order number and not the invoice number that was created. 

Cause

Copy control settings are not well configurated. 

Resolution

Go to the SSCUI 102764 - Define Copying Control for Billing Document to Billing Document and set the reference number to E (Actual Billing Document Number).

Keywords

KBA , SD-BIL-IV , Processing Billing Documents , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions