Symptom
You created a KUT field and you are not seeing it as a placeholder option inside a template/workflow rule. You may see other extension fields available, making you wonder why this happens.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales/Service work center.
- Open the Templates work center view.
- Open template ABC (where ABC is the name of the template you are working with).
- In the Placeholder section, open the drop-down menu for options available.
You do not see KUT field DEF available (where DEF is the ID of your created extension field).
OR
- Go to Administration work center.
- Open the Workflow Rules work center view.
- Click in the + icon.
- Fill in information until you reach step 3.
- Select an action that allows for placeholder definition (like E-mail).
- In the Placeholder section, open the drop-down menu for options available.
You do not see KUT field DEF available (where DEF is the ID of your created extension field).
Cause
The placeholders with 1:N cardinality are removed for the list of options in the two cases (templates and workflow) as value replacement for these are not supported.
Resolution
This is the system current standard behavior.
The node on which you choose to create a KUT field decides the cardinality of it.
For example: If you are adding a KUT field on Products table of an Opportunity screen, one opportunity can have many products, hence the KUT field would be of 1:N cardinality.
The intended design of a placeholder is to be replaced with the values of the Business Object which are mapped. Example considering a placeholder #1#:
If #1# is mapped to opportunity name: #1# will be replaced with Opportunity Name of the instance where the interaction is happening.
If #1# was mapped to Opportunity Products table/some other 1:N cardinality: It would be impossible to determine which value of the many products/records need to be selected.
Keywords
Template ; Extension Field ; Cardinality ; Workflow Rule ; Placeholder ; , KBA , LOD-CRM-SC-TMP , Template , LOD-CRM-OPP , Opportunity Management , How To