Symptom
Payment Batch Status not updating from Sent to Bank to Completed in Monitor Payments app after payments have been received in bank statements and cleared automatically during the processing of Electronic Bank Statements.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to app Monitor Payments.
- Enter the specific input parameters.
- Click on Go.
- Select tab Sent to Bank.
- Batch Status Text of Payment Batch displays Accepted by bank, even after the specific payment has been received in bank statement and cleared automatically.
Cause
App Monitor Payments only displays the status of Payment Batch from CRM. If the status is not updated during the processing of Electronic Bank Statements, there is no update in app Monitor Payments and the Payment Batch stays in it's last status (e.g. Accepted by Bank).
The status of payment batch is not updating from Sent to Bank to Completed because a different interpretation algorithm is used. Hence, no update happens towards BCM (Bank Communication Management) and the batch status remains the same (in most cases Accepted by Bank) in app Monitor Payments.
Resolution
The payment batch status will only get updated if interpretation algorithm 19 is used.
The status of Electronic Bank Statements can be viewed in app Manage Bank Statements.
See Also
Keywords
S4_PC, Monitor Payments, Completed, Sent to Bank, Accepted by Bank, Payment Batch, Batch Status, Interpretation Algorithm, Electronic Bank Statements, Manage Bank Statements, Bank Communication Management , KBA , FIN-FSCM-BNK , Direct Bank Communication , Problem