SAP Knowledge Base Article - Public

3137123 - Approval Process is not Working for Second Level

Symptom

The second step approval process is not triggerred automatically.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to the Service workcenter.
  2. Go to the Tickets view.
  3. Meet the conditions for the first approval process. Approval is triggerred.
  4. Now, meet the conditions for the second step approval process. Approval is not triggerred. 

Cause

With the first Approval , 'Approval Status' will set to 'Approved'. Now when the condition is met for the second step , we have a pre-condition for Auto Approval where we allow only if additional conditions are met. To avoid recursion of Approvals , we allow the Auto Approval process only once. Multi Step Approval does not match the conditions one step at a time ,one step meets conditions or all(if all the steps conditions are met at once , all Approvals will be triggered automatically).

 So technically it is not possible to determine which step's conditions are met and which steps are approved in a Multi-step approval process.

Resolution

This is the expected system behavior.

If you consider there to be a need for change within the system, we would like to kindly ask you to post this idea in the forum ( https://influence.sap.com/SAPCloudforCustomer).

Keywords

Second Approval, Approval Status. , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2111