SAP Knowledge Base Article - Public

3137123 - Approval Process is not Working for Second Level

Symptom

The second step approval process is not triggerred automatically.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to the Service workcenter.
  2. Go to the Tickets view.
  3. Meet the conditions for the first approval process. Approval is triggerred.
  4. Now, meet the conditions for the second step approval process. Approval is not triggerred. 

Cause

With the first Approval , 'Approval Status' will set to 'Approved'. Now when the condition is met for the second step , we have a pre-condition for Auto Approval where we allow only if additional conditions are met.

This process ensures that the system avoids recursive approvals by allowing the automatic approval to happen only once.

In the case of multi-step approvals, the conditions are checked collectively rather than one at a time. If all the steps' conditions are met simultaneously, all required approvals will be triggered automatically.

Resolution

This is the expected system behavior.

If you consider there to be a need for change within the system, we would like to kindly ask you to post this idea in the forum ( https://influence.sap.com/SAPCloudforCustomer).

Keywords

Second Approval; Approval Status; Multi approval; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions