SAP Knowledge Base Article - Public

3137527 - Numbering gaps can be seen between Service Orders

Symptom

  • Service Order numbering is jumping and skipping numbers. 
  • There are multiple missing service orders on our system, sometimes 2 or 3 in sequence.

Environment

  • Service Management (CRM)
  • SAP S/4HANA Cloud All versions 

Cause

The number range object for service orders (CRM_SERVIC) has buffering activated. When number ranges are buffered, in this case 10 numbers are made available to the application server - the database is not updated, a block of numbers are reserved for the server. If the server is upgraded, shutdown, etc the existing number range will be reset. This is largely the reason for numbering gaps on buffered internal number ranges.

Other reasons maybe related to a termination during processing, where the service order never actually gets committed to the database.

Resolution

Check the system error logs for terminations on the system.

If no terminations exist on the system, it is likely that the behavior is a result of number range buffering and is not an error. 

If further confirmation is required, please raise an customer case with SAP.

Keywords

SAP_BR_CUSTOMER_SRVC_MGR, CRMS4_SERV_ORDER_CONF_MANAGE_SRV, ServiceOrder, F3571A, GAP, SKIP, lost, removed, archived, not found,  , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions