SAP Knowledge Base Article - Public

3139400 - Deployment location - Problem connecting to server, Please check the hostname and port number

Symptom

When trying to conclude the deployment location setup, the system returns a validation error: Problem connecting to server, Please check the hostname and port number.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Learning admin side > System Administration > Configuration > Content Deployment Locations >
  2. Add New > Fill out the fields > Add > Validation Error >
  3. Or > Access the desired deployment location > Modify the desired fields > Apply Changes > Validation Error.

Cause

The data center which the iContent account, being used in the deployment location setup, belongs to differs from the data center the Learning environment is located at.

Resolution

When doing the deployment location setup, make sure to use the iContent account and the Learning environment which are part of the same data center.

See Also

2251749 - How to Setup a Deployment Location in SuccessFactors Learning

2396085 - iContent Launch URL Prefix for each datacenter to be used in Deployment Location

2250792 - SFTP Public IP Addresses and URL's for Data Centres

Keywords

Problem connecting to server, Please check the hostname and port number, icontent, account, deployment, location, setup, error, validation, environment, data, center , KBA , LOD-SF-LMS-PCM , iContent , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions