Symptom
You have setup Ticket Routing Rules to determined Territories for Tickets and notices that, although they work fine on Ticket creation, if changes are done the Territory is not updated based on the Rules.
Environment
SAP Cloud for Customer
Cause
Unlike Team and Processor, for Territory, the Ticket Routing Rules only work on creation.
Resolution
To make this work on change, you need to create a Workflow Rule with timing On Every Save and Action - Determine Territory.
Doing this, the rules will be evaluated on every change to see if there is a need to update the Ticket Territory.
Keywords
determination ; ticket ; territory ; role code ; routing rules ; service and support team ; ticket for customer support ; fine tune , KBA , LOD-CRM-SRP , Service Request Processing , How To