Symptom
A wrong G/L account when posting cash discount on Post Incoming Payment
Wrong G/L account is automatically determined. It should be 11002100 instead of 11002000
Environment
S/4HANA Cloud All versions
Reproducing the Issue
1. Open app "Post Incoming Payments"
2. Enter data as per attached screenshots
3. Click "Simulate"
4. Wrong G/L account is automatically determined. It should be 11002100 instead of 11002000
Cause
You are using "Post Incoming Payments". Within this app, the automatic account determination for SD
Sales->Sales Billing->Assign G/L Accounts->V(Sales/Distribution)>C001(Cust.Grp/MaterialGrp/AcctKey)
It will not work since you are using a FI app. This is also valid, if the related journal entry to be cleared was posted via SD.
Resolution
Please use our FI account determination, instead:
1. Open SSCUI "Automatic Account Determination" (ID: 100297)
2. - Area: Financial Accounting
- Subarea: Accounts Receivable and Accounts Payable
- Process: Define Accounts for Payment Transactions
- Transaction key: SKT
- Chart of accounts: <YOUR-CHART-OF-ACCOUNT_e_g_YCOA>
3. Change the currently assigned accounts "11002000" to e. g. "11002100".
Then, while posting in app "Post Incoming Payments", GL-account "11002100" should be used, instead of "11002000".
Keywords
Automatic Account Determination; G/L account; Sales Billing; Post Incoming Payment; Cash Discount , KBA , FI-GL-GL-A , Posting/Clearing , Problem