SAP Knowledge Base Article - Public

3140759 - onInit Business rule setting Manager/ Supervisor field works for Hire user, but not for Rehire user

Symptom

System have an onInit business rule under jobInfo of Manage Business Configuration that automatically sets the logged-in user in the Manager field. For a new Hire, the Manager will be set; but if it is a Rehire user, the manager will not be set.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

SAP SuccessFactors Employee Central: Hire & Rehire Wizards

Reproducing the Issue

  1. Go to any of the profiles under Rehire Inactive Employee tool
  2. Choose hiring template and reach till Job Information (by filling some dummy values)
  3. Can see Manager field have no value (expected to be set by the rule as shown below)

             

       4.Check Employee Export of user, can see these name fields is not getting updated

  1. Same scenario when Add New Employee and Accept Match
  2. On rule trace, the value we can see is getting set
  3. Also on normal Hire scenario, the value is getting set

Cause

This is working as per design. System have a hardcoded logic to clear out value for some of the fields in jobInfo during rehire, and these fields include manager, position, notes fields. So even an onInit rule setting value to one of these fields, it will be cleared during Rehire flow.

Resolution

To default a value to manager, position, notes fields using a business rule, then have to associate those rules to onSave of jobInfo under Manage Business Configuration.

Keywords

hire, rehire, wizard, onInit, Manager, Supervisor, Business rule, inactive, onSave, jobInfo, position, notes , KBA , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem

Product

SAP SuccessFactors Employee Central all versions