SAP Knowledge Base Article - Public

3141240 - How to change the status of the user from active external suite (e) to Inactive external suite (d) - Onboarding User Purge

Symptom

Unable to purge the candidate using "Purge Inactive User".

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Cause

Status of the candidate is not changed to "d" (inactive external suite) but remains "e" (active external suite).

Steps to check: Go to Admin Center -> Data Inspector -> Table_USERS_SYSINFO -> "Valid" field

Resolution

Note :  One should be cautious here. Please perform these steps only if User Status is "e" 

Update the external candidate status from "e" (active external suite) to "d" (inactive external suite) 

The status of the candidate can be changed from the Integration Center:

  1. Go to Admin Center - > Integration Center -> My Integrations
  2. Click on "Create" -> More Integration Types
  3. Select as below -> click on "Create"
    • Trigger Type: Scheduled
    • Source Type: SuccessFactors
    • Destination Type: SuccessFactors
    • Format: OData v2

       

  4. Select Entity "ExternalUser" -> click on "Select"



  5. Click on "Configure Fields" option



  6. Select "Upsert Single" under Operation 

      

  7. Select "userId" field -> click on "Set as Associated Field" button (the highlighted icon)



  8. Go to "Entity Tree View" -> select "userId" -> click on "Change Association to Selected Field"



  9. Find "Filter" field -> enter user id of the candidate whose status needs to be changed



  10. Similarly, select "loginMethod" field -> click on "Set as Associated Field" button -> go to "Entity Tree View" -> select "loginMethod" -> click on "Change Association to Selected Field"
    (※ No need to add Filter.)





  11. Similarly, select "Username" field -> click on "Set as Associated Field" button -> go to "Entity Tree View" -> select "Username" -> click on "Change Association to Selected Field"
    (※ No need to add Filter)


     

  12. Select "status" field -> find "Default Value" field -> enter value "d"
    (※ No need to click "Change Association to selected field” button, just enter "d" in Default Value field.)

     

  13. Similarly, select "productName" field -> find "Default Value" field -> enter value "ONB"



  14. Click on "Next" till reach "Review and Run" page



  15. Click on "Run Now" button -> wait till the Job is run successfully -> click refresh button behind "Last Run Time" to check.
    Once it's completed, the status changes to "d".
    (※ You can double check in Data Inspector -> Table_USERS_SYSINFO -> Valid field.)



  16. You can do "Purge Inactive User" for the candidate now (please refer to KBA3052056).
    Also View: 3375924 - How To check User Status Via Data inspector

See Also

  • 3052056 - How to delete or permanent purge an inactive onboardee user - Onboarding 
  • 2545988 - How to Purge/Delete users in SuccessFactors 
  • 3375924 - How To check User Status Via Data inspector
  • 3319018 - How To Enable Feature Data Inspector

Keywords

Change user statue from e to d, Unable to purge, Purge, Onboarding, change, update , KBA , LOD-SF-OBX , Onboarding 2.0 , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , Problem

Product

SAP SuccessFactors Onboarding all versions

Attachments

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