Symptom
You can see no results within a recently deployed PDI(Custom) Data Source.
Environment
SAP Cloud for Customer - All Versions
SAP Business ByDesign - All Versions
Reproducing the Issue
1. Go to Business Analytics work center
2. Go to Design Data Sources work center view
3. Search for the Custom Data Source you just deployed in Production
4. Preview it
5. You can see no results
Cause
This occurs whenever a custom solution(PDI) is Deployed to a Productive System but it is not added to the Implementation Project Scope.
Resolution
In each and every Custom Solution(PDI) there will be a BAC element where a Scoping Question is defined. This is responsible for enabling and disabling your Add-On in the Productive System.
To have the Add-On enabled to show it's data in Production the Scoping Question defined for your custom solution has to be marked in the Implementation Project Scoping.
In case of the custom solution is correctly added in Scoping but the issue still occurs, you can create an incident with SAP Support.
Keywords
Custom Data Source; No Results; Scoping; , KBA , AP-RC-BDS-ANA , ByDesign Studio Analytics , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem