Symptom
Self-Service user cannot upload supplier invoice via SAP Collaboration Window.
The upload of PDF is not successful. The PDF is moved into Upload Error folder after some time.
Environment
SAP Business ByDesign
Cause
User is not able to upload supplier invoices via collaboration tool because user doesn't have the required access rights.
Besides Work Center / View ID 'SRM_INVOICESCANNING', 'SRM_INVOICESANDCREDITMEMOS' is also needed for the uploading.
Resolution
User will be managed to upload invoice with Work Center / View ID 'SRM_INVOICESANDCREDITMEMOS' assigned to Business Role.
Please note that this Work Center/ View ID is of User Type 'SAP BYDESIGN FOR CORE USE', so this will change the user licence from Self-Service to Core.
However this is currently expected system behaviour.
(Also remove 'SRM_INVOICESANDCREDITMEMOS' from Business Role & licence type of user will be reverted back to Self-Service).
Keywords
Collaboration Window, Supplier Invoice, Upload Error, Collaboration Tool, Access Right, SRM_INVOICESANDCREDITMEMOS, Self-Service User, Business Role , KBA , SRD-SRM-PRO , Purchase Requests and Orders , Problem