Symptom
- You are trying to create a workflow rule for Contact (or custom) where the field you are trying to reference is the "Function" (BusinessPartnerFunctionTypeCode) field under the Contact view
- However, in step 2 (Defining Conditions), there is no option to select the "Function" field as a parameter condition
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open the "Workflow rules" WC
- Enter basic data and select business object "Contact" or whatever custom view you want to use, and set the timing per requirements
- In step 2, add a new condition group (at this point, the expectation is to see the "Function" in the dropdown list as a condition), but such option is not available for selection
Cause
Field is not available by default
Resolution
- Conditions are the criteria which trigger workflow rules. These conditions may be standard fields, extension fields, field value change, and so on.
- By default, not all fields are available as conditions for workflow rules
- Currently, the "Function" the field is not available to be used as condition in the Workflow Rule
- If customers would like to have such option as condition in the Workflow Rule, it would be a change request on the current system standard behavior.
- Customers can post an enhancement request via the SAP Customer Influence Program. Check KBA 2531650, for more details
- The idea posted will trigger engagement with other peers from our Product Management team to evaluate its feasibility
- Customer can can also create conditions using custom (adapted) fields
- Set up any custom fields first, before you create your workflow rules
- See "SAP Cloud for Customer Extension Guide", for more details
See Also
2838843 - Rule Type Action Is Not Available when Setting a Workflow Rule for Custom BO
Keywords
Work flow, workflow, condition, condiciones, Contact Person, Defined conditions, C4C, Services, Sales, Contact , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-CON , Contact , Problem
Product
SAP Cloud for Customer core applications 2111