SAP Knowledge Base Article - Public

3142818 - Field data wiped out from employee profile - Employee Central

Symptom

Issue can be caused after after changing field identifier in business configuration all employee data got wiped out.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to any field in Admin Center > Manage Business Configuration
  2. Change it's identifier
  3. All data in UI will get wipe out

Cause

Whenever the identifier of the field is changed, the data won't be visible because it is not being referenced to the same variable as it was before.

Resolution

If you need to preserve the original value in the field then please change the identifier back to the original one and the value will be back to the field.

Keywords

BCUI, Manage Business Configuration, Identifier, field, erased, wiped out, value, removed, , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions

Attachments

Pasted image.png