Symptom
Onchage rule is defined on a job information field however this rules does not trigger.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Configure a "custom-string1" field on global Job Information.
- Configure a "custom-string1" field on Country Specific Job Information - jobInfo_XXX
- Assign the onChange business rule on "custom-string1" on global Job Information.
- Navigate to Employee > Job Information.
- Edit the field.
- OnChange rule is not triggered.
Cause
Field which holds the rule was defined in global job information and on country specific data model as well, however the rule is not defined in the country specific data model.
Resolution
You can correct error removing the field from country specific configuration:
- Go to Manage Business Configuration
- Select Job Information country specific
- Remove the field from there and use just field in global job information.
or Add the same rule against the same field in country specific:
- Go to Manage Business Configuration
- Select Job Information country specific
- Go in the field and configure same rule there.
Keywords
onchange, on change, rule, not, triggering, country, specific, working, run, business rule not triggered, OnChange rule not working, Trigger onChange business rule for HRIS elements, rule not working on field. , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC , Employee Central , Problem
SAP Knowledge Base Article - Public