Symptom
Onchage rule is defined on a job information field however this rules does not trigger.
Environment
SAP SuccessFactors Employee Central
Cause
Field which holds the rule was defined in global job information and on country specific data model as well, however the rule is not defined there in the country specific data model.
Resolution
You can correct error removing the field from country specific configuration:
- Go to Manage Business Configuration
- Select Job Information country specific
- Remove the field from there and use just field in global job information.
Adding the same rule against the same field in country specific:
- Go to Manage Business Configuration
- Select Job Information country specific
- Go in the field and configure same rule there.
Keywords
onchange, on change, rule, not, triggering, country, specific, working, run, , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions