SAP Knowledge Base Article - Public

3143270 - Onchange rule is not triggered on job information field - Employee Central

Symptom

Onchage rule is defined on a job information field however this rules does not trigger.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Configure a "custom-string1" field on global Job Information. 
  2. Configure a "custom-string1" field on Country Specific Job Information - jobInfo_XXX
  3. Assign the onChange business rule on "custom-string1" on global Job Information.
  4. Navigate to Employee > Job Information. 
  5. Edit the field. 
  6. OnChange rule is not triggered.

Cause

Field which holds the rule was defined in global job information and on country specific data model as well, however the rule is not defined in the country specific data model.

Resolution

You can correct error removing the field from country specific configuration:

  1. Go to Manage Business Configuration
  2. Select Job Information country specific
  3. Remove the field from there and use just field in global job information.

or Add the same rule against the same field in country specific: 

  1. Go to Manage Business Configuration
  2. Select Job Information country specific
  3. Go in the field and configure same rule there.

Keywords

onchange, on change, rule, not, triggering, country, specific, working, run, business rule not triggered, OnChange rule not working, Trigger onChange business rule for HRIS elements, rule not working on field.  , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions