Symptom
You wish to add a C4C Custom Field to Server Side Outlook Add-in, however there is no option to add this field from the list.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the workcenter E-mail Integration > Groupware Settings.
- Profile > Open the desired Profile.
- Go to Add-in Settings.
- Go to the object in question.
- Click Detailed View.
- Click 'Add Field to detailed View'.
- Here you can see that there is no option to add the desired custom field, for example 'Activity Type'.
Cause
You need to add this field to the correct odataservice. For example, in this case it is "Activity".
Resolution
To make the field available in the Groupware Profile Add-in settings, please add the required extension field to the odataservice ex. "Activity" via the Edit Field screen in the adaptation mode on the Visit OWL/QC where the field has been added to the regular UI.
Keywords
add custom field, outlook add-in , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To