Symptom
You have added the extension field, KUT (Key User Tool) type, to c4codata service, but the field is not available to be added to a specific object in the groupware add-in settings of a profile.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to E-mail Integration Work Center.
- Enter Groupware Settings view.
- Navigate to Profiles tab.
- Open the affected profile.
- Navigate to "Add-in Settings" tab and find the affected object, for example Opportunity.
- Click on "Add Field to Detailed view" and search for the affected custom field.
- Result: The custom field is not available for selection.
Cause
The c4codata service is deprecated.
Resolution
Add the KUT field to the affected odata service object, for example opportunity.
See Also
Keywords
Add Field to Detailed view, Groupware Settings, Server Side, Custom Field, KUT, Extension , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2111