SAP Knowledge Base Article - Public

3143351 - Language error when trying to Upload Service Category Catalog

Symptom

  • You are trying to upload a new catalog using the CSV file
  • The process fails with the error: "Category ID CategoryID has invalid language Language1."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to "Administrator"
  2. Select "Service and Social"
  3. Choose the Service Categories (under SLA Setup)
  4. Select "Catalog From File" -> "Select File" -> Select "Exclude Column Headers"
  5. Browse for the CSV file and hit "Upload" -> the system will throw the error "Category ID CategoryID has invalid language Language1."

Cause

Missing mandatory data not included in the CSV file

Resolution

  • Please ensure all the mandatory data is provided in the CSV file provided
  • See "Upload Service Category Catalog"
  • For example, since in this case the Language1 entry is missing, ensure the desired language ID like EN (for English), (PT for Portuguese) etc, is included in the file
  • For a complete list of supported language codes, refer to SAP Cloud for Customer System and Software Requirements.

Keywords

 O ID de categoria CategoryID possui o Idioma Language1 invalido, upload, catalog, language , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2111