SAP Knowledge Base Article - Public

3143671 - Wrong Name Displayed in the Search - SAP SuccessFactors

Symptom

Searching for an employee in the global search header display a wrong name in the result.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

Search for a user and the name displayed in the result includes an incorrect name

Example:

  • Here I have searched for employee "John Doe" but in the result I see "John Example Doe"
  • We see the user has the correct First and Last name per the quick card displayed
  • If you check the users profile of the UDF (employee export) file, you also see the user has the correct first and last name. This middle name we see in the search is not maintained anywhere

Cause

  • This is one possible cause, it may not always apply.
  • If an option in Provisioning called "Enable Name Format" is enabled, it will cause the User Search to display the value maintained in the "Formal Name" field.
  • In a lot of cases "Formal Name" is not enabled and/or permissioned so you do not see this on the profile page and so you cannot confirm the wrong name you are seeing in the search result is coming from this field.
  • The formal name is an Employee Central field which may have been set when the user was created in Employee Central, either incorrectly or the user may have changed their name since creation.

Resolution

  1. Confirm that name format is enabled
    • By support or by a partner, this can be confirmed by checking in Provisioning > Company Settings - if the option "Enable Name Format" is ticked;
    • If so you you can also confirm if the wrong name in the search is caused by this option by disabling it and saving - then login to the instance and search the user. If the correct First and Last name is displayed, you know the issue coming from Name Format > where the formal name is displayed (enable Name Format again as it is probably enabled for a reason, unless confirmed by the customer it is not required);
    • Customer can confirm if Name Format is enabled navigating to "Manage Data" > search for "Name Format". If it is found then it is enabled;
    • To confirm if the Name Format is being used, customer can navigate to Configure People Profile > General Settings > Check if there's a Name Format maintained in "Choose Name Format" dropdown.

  2. Check if Formal Name is Enabled
    • Go to "Manage Business Configuration" > on the left side expand Employee Central > HRIS Elements > find and click into "personalInfo" (if you do not have Employee Central > HRIS Elements then you are not using Employee Central and this issue/solution does not apply to your instance)
    • From the list of HRIS Fields look for "Formal Name" and check if the "Enabled" option is set to "Yes"
    • If the "Formal Name" field is not there - add it - the last HRIS field displayed will always be "No Selection" where you can add any personalInfo fields not already showing
    • Scroll to the bottom and save
  1. Permission your user to have the "View" permission (to be able to see the field on the profile to confirm it is coming from this) and the "Edit" permission (to be able to correct the problem name)
    • Go to Manage Permission Roles > Select a role you user currently belongs to (changes you apply here will apply to any use included in this role) > under "Employee Central Effective Dated Entities" > find "Formal Name" and give yourself the required view/edit/correct/delete permissions per your requirements
    • Ensure you save
    • Note: If it's not feasible for customer to give this permission, they can also pull a Person and Employment Export report selecting "formal-name" to check what's the data maintained for the referred user.
  2. Now if you check the profile of the user with the wrong name you will see the field for "Formal Name" and the value that is maintained.
    • In some cases you may need to click on "View More" to see it.
    • You may need to refresh or log out and back in for the changes to apply
  3. Edit the details to correct the problem
    • Click on the "Edit" icon as highlighted above
    • Correct the "Formal Name" and save
  4. Now the "Formal Name" is correct on the profile and this is reflected in the search result
  5. If required, remove the permissions and disable the formal name again.

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Implementing Name Formats

See Also

  • 2385804 - Supported Fields for People Search
  • 2444264 - How to display employee's preferred name in Quick Card and People Search - Employee Central
  • 2295729 - Name Format: Changing the Name Format Assigned to Legal Entity will not dynamically update Formal Name for Employees
  • 2274066 - How to use Name Format functionality in Employee Central
  • 2297189 - Name Format: Where in the UI is Name Format Respected?
  • 2922553 - Unable to search employee by Display Name

Keywords

Wrong name, Search, Formal Name, last name, first name, name format , KBA , LOD-SF-PLT-SRH , Search , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors HCM suite all versions

Attachments

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