SAP Knowledge Base Article - Public

3145161 - New Contact Button Not Available In Lead Conversion Screen Despite Being Marked As Visible

Symptom

The 'New Contact' button is not available when converting leads.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work centre
  2. Go to the Leads view
  3. Create a new lead without contact
  4. Click Actions -> Convert Lead to Opportunity
  5. In the new window, open the "Primary Contact" field OVS
  6. The "New Contact" Button is not available - despite being marked as visible in Adaptation.

Cause

This is the current expected system behaviour by design.

The button 'New Contact' is not available during Lead to Opportunity conversion.

The button shows in Adaptation mode as this window shares its basic frame with the New Opportunity creation screen.

Resolution

In Adaptation mode you will see fields that are related to the basic UI frame of a view.

This means, a field/ section/ facet/ etc. might show up and be set to visible that has another condition set by the system before it will actually show up in the UI.

For example, the Employee field is only available in the 'All Accounts' query, because in the 'My Accounts' query, the logged in user is already set as employee by default for that query.

Another example could be the Territory fields, which depend on your Territory scoping (Multiple vs Single Territory scoping) or certain elements are available on a SALES contract, which are not visible in a SERVICE contract, etc.

Should your business require a change to the system behaviour you can consider creating a custom solution (PDI) or you can post this new request on our influence page:  https://influence.sap.com/sap/ino/#/campaign/1868
Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.

See Also

Similar scenario: KBA 3144696 - Field "Employee" Not Visible In 'MY ACCOUNTS' Query

Keywords

KBA , LOD-CRM-LM , Lead Management , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer core applications 2111