Symptom
Upon performing an upsert OData API request, the following response is returned:
{
"error": {
"code": "BadRequestException",
"message": {
"lang": "en-US",
"value": "Upsert content exceeds the limitation, the maximum size is 1000"
}
}
}
Environment
SAP SuccessFactors HXM Suite
- OData API
Cause
The amount of records in the upsert request payload exceeds the limit of 1000.
Resolution
It is not possible to upsert more than 1000 records in a single request. If the amount of records exceed 1000, you must divide them between separate upsert requests of 1000 records or less.
Upsert is an expensive operation and the processing time of this operation for each record depends on:
- The complexity of your upsert payload;
- The entity being upserted;
- Multiple configurations in your system (amount and complexity of business rules associated to the object, workflows, etc.)
Therefore, it is not always recommended to upsert 1000 records in a single request, which is the upper limit. The upsert request may fail with a timeout error even if the amount of records is within the limit of 1000, and therefore it may be necessary to lower the amount of records per upsert request if you are observing timeout errors.
Keywords
upsert, error, fail, limitation, one thousand, records, content, payload , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem