Symptom
You are working with tickets via e-mail channels and notice that emails with another e-mail attached have the attachment name changed to "noname".
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Select the Tickets view.
- Open Ticket ID ABC (ABC represents the Ticket ID).
- Go to the Interactions tab and open the e-mail.
- On the e-mail, go to the Attachments tab.
- You can see a file "noname.eml" (it may be .msg).
This was not the original file name.
Cause
The name of the file for extensions is taken from the "Name" field on the file code. For e-mails, the MIME Type on the system is "message/rfc822" and for this MIME, the "Name" field is not present. Since there is no name on the code, the system sets the file name to "noname" and the extension.
Resolution
The Customer Email provider, must adjust the Mime from its provider, which is being sent to SAP.
Example of a correct mime formating (where the Name is present)
Example of an incomplete Mime (where the Name is missing and hence the "noname" behavior will occur:
Content-Type: message/rfc822
Content-Disposition: attachment;
creation-date="Wed, 12 Dec 2023 10:55:21 GMT";
modification-date=""Wed, 12 Dec 2023 10:55:28 GMT"
Content-ID: <2E169C2EF413E4458D25C103EC22A6CB@XYZ.ch>
See Also
2490763 - Cannot Open Attachment Type Email in Tickets
Keywords
e-mail, mail, msg, mht, subject, file, attachment, noname, missing , KBA , LOD-CRM-SC-EML , Email , How To