Symptom
The data source "Service Assignment" shows the start and end dates in the wrong time zone.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Business Analytics.
- Go to the view Design Data Sources.
- Search for "Service Assignment" and click Preview.
- You can filter for an ID to reduce the number of service assignments shown.
- Run the data source.
- In the view, add the fields Start Date/Time, Start Date/Time Time Zone, End Date/Time and End Date/Time Time Zone .
- It is shown in UTC for example, however the service technician's time zone is a different one.
Cause
The timezone refers to the timezone in which the assignment was created/updated. i.e. the service manager's timezone.
Resolution
If you would like to suggest changes / enhancements to this behavior, please make use of the Influence Portal.
Keywords
service assignment, data source, business analytics, wrong time zone, CRMSRVASSGN_U , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To
Product
SAP Cloud for Customer core applications all versions