Symptom
You have defined a new Color Categorization for the Calendar based on the Visit Type. However, in Offline Mode, only the default colors on status are visible.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login in the system.
- Sync Offline data.
- Go Offline.
- Go to the Calendar view.
- Note that the Activities color categorization is set to the default colors.
Cause
Calendar uses a third-party library called "Kendo Scheduler" for rendering the activities and color coding. Currently, it does not support complex color configurations in Offline Mode.
Resolution
This is the expected system behavior.
Keywords
Offline Mode. Calendar. Color Categorization. , KBA , LOD-CRM-CAL , Calendar Control , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2111