SAP Knowledge Base Article - Public

3147097 - Virtual (VLS) Enabled Class - Unable to Change User Registration Status

Symptom

When accessing a virtual class record and attempting to change the Registration Status of a user, the system does not save the change.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Go to Learning Administration > Learning Activities > Classes
  2. Access a Class that has VLS
  3. Go to the Registrations tab
  4. Change a user's Registration Status from Cancelled to Enrolled
  5. Apply Changes
  6. The Registration Status does not change on the Registration Tab

Cause

The cause can differ depending on VLS vendor. If a user has been enrolled with the same email address as another user, the email is already in use and there cannot be two users enrolled with the same email address.

Resolution

  1. Go through User records to validate that there are no duplicate emails that utilize virtual classes
  2. Check on the VLS Vendor's reports to see which user already utilized the email address and correct the information, if possible.

Note: Due to VLS vendors being 3rd party, SAP cannot provide guidance on how to change or update the data on the vendor side.

Keywords

Unable, cannot, can, not, change, update, user, registration, status, vls, vle, webex, class, learning , KBA , LOD-SF-LMS-SCH , Class - Scheduled Offerings , LOD-SF-LMS-VLS , Virtual Learning System , Problem

Product

SAP SuccessFactors Learning all versions