Symptom
Unable to create 'Canvas report' .
User receives error "Error response for getSupportedlanguages on accessing WFA endpoint /SupportedSfLangCodes with response code 401", even though all configuration related to Canvas Reporting is set correctly in Provisioning and Analytics backend.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Analytics & Reporting (Ad Hoc, YouCalc, ORD)
- Advanced Reporting (ODS)
- Detailed Reporting - live data
- Analytics & Reporting (Ad Hoc, YouCalc, ORD)
Reproducing the Issue
- Login to instance
- Navigate to Report Center
- Click New and select Canvas
- Pop up "Error response for getSupportedlanguages on accessing WFA endpoint /SupportedSfLangCodes with response code 401", appears when users try to create Canvas Report
Cause
1. User may not be available in user maintenance
2. There can be other user with same username in user maintenance
Note: In the Analytics backend user maintenance, the username is case insensitive.
Resolution
We can follow below two solution to fix the issue:
1. Please reach out to SAP support team to add configuration from back end to auto create users in User Maintenance.
2. You can either delete the existing user who has same username as in other impacted user.
- Go to Report center
- Click on View Schedules -> Switch to legacy distributor tool
- Click on Admin (Top right corner)
- Now go to 'User maintenance'
- Search for user and delete
3. Change the username of the reported user from SF system, navigate to Report center and click on Canvas Report.
Note : Instance has GDPR setup configured. You will notice this if you see the note "(Change logging is on)" next to User Summary in User Maintenance section
See Also
Keywords